Welcome to mybenz | mysatisfaction !, Register here.. | Home | Directory | Events | Forum | Buy and Sell | Contact Us | Planet Mybenz  
Recent Forum Topics
Topic Replies/
Views
Last Post
W245 B170 Transmission Visit Workshop error 0/117 2020/4/1 21:42 Brother
Repair Lamella Sunroof W245 B170 0/117 2020/4/1 19:44 Brother
TT session 2020 in Penang 2/556 2020/3/9 20:48 Golfer
TT Session in Penang 2018 12/3286 2020/2/28 23:06 Golfer
Banner Battery 2/827 2020/2/28 23:04 Golfer
Black stain on saddle brown nappa seats 0/809 2020/1/30 21:54 Rey
updated tire price list 216/104132 2020/1/30 18:02 lgxrkz
W212 E-Classe Owners 75/16723 2020/1/10 9:15 exidus
Merry Christmas 0/978 2019/12/24 22:45 Golfer
Dynamic shock absorbers replacement 3/1706 2019/12/6 15:31 126208W
Flipkey replacement needed 0/494 2019/11/17 0:34 alvin488
How to activate Navi in W204 0/522 2019/11/14 16:42 MaN_MoRiNi
W211 aircond wshop 1/755 2019/11/5 19:16 JavaKajang
W124 E280 MP PArts and Maintenance 1/944 2019/10/18 17:35 ChrisG76
w210 SERVICE CENTER(CHEAP AND BEST) 1/1149 2019/9/22 16:53 han
SRS LIGHT ON - 124 0/1122 2019/9/10 16:05 skcsec
W210 half cut Front Bumper 0/742 2019/9/5 17:30 dudelouv
Hello guys 0/760 2019/8/30 11:03 mal
W202 C220 1996 auto 0/1164 2019/8/24 21:02 aridz1
GET TO KNOW : Our States Penghulu!! 84/21216 2019/8/23 16:42 Golfer
W212 windscreen replacement in JB 3/1862 2019/8/21 13:23 alexl
C200 W204 2011 Facelift - A personal review 260/46682 2019/8/14 5:50 enkil
1989 W124 300CE stalling while slowing down 1/2053 2019/7/21 12:27 rayray7279
190E 2.6 (Manual) 0/2302 2019/7/4 12:08 cossie_mozzie
Genuine Mercedes Benz E280 Masterpiece W124 (For Sale) 0/2925 2019/6/17 17:04 cossie_mozzie
Ideal engine transplant for 190E 2/2528 2019/6/14 9:56 cossie_mozzie
car idle and stall 5/1603 2019/6/11 22:48 Golfer
vibration on rev 1/2446 2019/5/15 21:00 Gan
Anyone knows what this button is? 3/3503 2019/5/15 18:42 Plinker
REPAIR MILEAGE METER - 124 MODEL 6/2728 2019/5/7 17:43 Plinker
Two Doors with or without tops Mercedes Members 214/42564 2019/4/11 14:55 126208W
Auxiliary fan brand recommendation 1/2604 2019/4/7 0:16 shiningstar
E300 HYBRID ( Blue tech) Diesel 0/2658 2019/3/26 22:44 SERVICOM
Groovy Sunshade Bulk Purchase 15/8166 2019/3/18 1:17 techjack
WHO R YOU? 334/53964 2019/3/4 14:01 benz-lover
Madeline 19/5170 2019/3/4 12:17 deezed
Kipas laju sedangkan temperature 80-95 0/2269 2019/2/26 15:54 adhary
Subwoofer W212 3/4052 2019/2/2 23:44 Mabel
Good Night... 165/25826 2019/1/12 0:51 Mabel
W211 Members 197/46923 2019/1/12 0:47 Mabel
Battery drain 3/3774 2019/1/12 0:46 Mabel
Rusty water 5/5478 2019/1/12 0:45 Mabel
W124 E220 Japan model engine misfirng and stalling 3/3953 2018/12/21 21:41 Mabel
What are the different classes in Mercedes Benz? 2/3792 2018/11/30 21:51 Mabel
GEAR BOX - W220 S280YEAR 2000 2/3801 2018/11/30 21:41 Mabel
Kereta bergegar dan menggigil bila idle atau slow 1/3089 2018/11/30 21:37 Mabel
Mabel 112/28506 2018/11/8 23:47 Mabel
Mabellina 59/36006 2018/11/8 23:42 Mabel
New member from Bandar Baru Uda JB 31/8197 2018/11/8 23:22 Mabel
Just being Malaysian 162/26271 2018/10/26 22:15 Mabel
Login
Username:

Password:


Lost Password?

Register now!
Refine Search
Main Menu
Quick Access
Who's Online
10 user(s) are online (8 user(s) are browsing Forum)

Members: 1
Guests: 9

Brother, more...
Location and Benz Model
Please add your location and benz model by clicking on your "edit account" link . That way it will help other members to help you identifying your benz related problem or probably help locating nearest workshop for you .
Members vs Models
Vintage | A-Class | W123 | W124 | W126 | W140 | W201 | W202 | W203 | W210 | W211 | W220 | 
B-Class | M-Class | W204 | W221 | W212 | 2-Doors | R107 | R129 | R170 | R171 | R230
mybenz | mysatisfaction Forum Index
   Two Doors with or without tops
     C209 CLK200 M271 Engine (Year 2003)
Register To Post

Threaded | Newest First Previous Topic | Next Topic | Bottom
Poster Thread
vasan8525
Posted on: 2015/10/6 14:56
Just popping in
Joined: 2015/7/4
From: Sungai Buloh
Posts: 1
Benz Model: C209 CLK200
Message:
C209 CLK200 M271 Engine (Year 2003)
Hi Members I'm new to Mybenz.org and this is my first post...

My English is not good

I am driving a Mercedes-Benz C209 CLK200 Japanese Spec with M271 Engine. Bought it second hand last year August 2014 and K/M was clocked 57K+. Once I got the car I changed couple of things like suspension, arms, tyres. The mechanic noticed oil leaking from cam magnet solenoid. I changed both the sensors too. After 25k K/M of usage the car started to consume a lot of fuel. (from the meter it was showing like 16L/100KM that's quite a lot and loss of power too) finally I've got the CEL and I hooked up OBD2 scanner and found 2 errors P0171 and P0137. After couple of google search I've found out that this happens because of the engine oil leaks through the Cam Magnet Sensor and migrates to ECU, MAF and O2 Post Cat Sensor's connectors and alters the resistance from those sensors and make ECU the to misbehave. I have checked those said connectors and found oil contamination.

Solution:-
I took out whole engine wiring harness and soaked into soap water for 24 hours, and made it dry under the sun for 2 weeks and bought a can of CRC Contact cleaner, sprayed on all the sensors interface and wiring connectors to make sure 100% dry and clean. Mean time I've serviced the throttle body, cleaned intake manifold, changed to new intake manifold gasket. I have successfully installed the wiring harness back and started the engine and the engine runs smoothly and power also back to its original state. I cleared the fault codes. However the fuel consumption was still very high. After few minutes of test drive the CEL appeared again. I hooked up my OBD2 scanner and found P0171 error only. This time P0137 was not appeared.

I suspect it could be MAF Sensor issue. Has anyone faced this kinda issues? if yes please kindly share your solution

Best Regards,

Vasan
Mabel
Posted on: 2015/10/11 22:42
Benzo mania
Joined: 2007/8/7
From: Shah Alam, Cyber Jaya, Sunway
Posts: 20052
Benz Model: S320L, E240, C200
Message:
Re: C209 CLK200 M271 Engine (Year 2003)
Congratulation for having an ownership of this nice looking car. Actually I'm quite impressed with your ability to do DIY with the stuffs you mentioned above. From what I read the high fuel consumption are due to the fuel mixture being too lean meaning More Air Less Fuel.

A normal suspect could be either:

1. O2 sensors
2. MAF sensor
3. Leakage at the hoses at the MAF Sensor.

Basically consumption issues can be grouped into:-

- ENERGY CONVERSION ISSUES (fuel/air ratio, combustion efficiency, gear selection efficiency, engine/transmission internal drags etc,,etc,,).

- DRAGS (Under inflated tyres, binding brakes, overloaded car, tyres and wheels out of alignment, aerodynamic drag due to spoilers, etc,,, etc,,,).

- MECHANICAL & ELECTRICAL ISSUES (ECU management, spark plugs, ignition timing, fuel injection management, Turbo/Compressor efficiency, intercooler, inlet air temperature and volume, valve timing, compression losses, cold engine, high viscosity lub, etc,,,etc,,,).

So eliminate all that you can before proceeding to a workshop and spending good money.


----------------
Cheers/Mabel

Nothing great was ever achieved without enthusiasm
Take time to read. It is the fountain of wisdom
Membership Number: One Nine Seven Seven

techjack
Posted on: 2016/1/18 14:29
Just can't stay away
Joined: 2010/2/1
From: Kuala Lumpur
Posts: 149
Benz Model: W124 and W203
Message:
Re: C209 CLK200 M271 Engine (Year 2003)
Hello Bro Vasan

How is your car running after performing all the cleaning?

I think i cam facing the same issue as well now.

Many thanks.

Quote:

vasan8525 wrote:
Hi Members I'm new to Mybenz.org and this is my first post...

My English is not good

I am driving a Mercedes-Benz C209 CLK200 Japanese Spec with M271 Engine. Bought it second hand last year August 2014 and K/M was clocked 57K+. Once I got the car I changed couple of things like suspension, arms, tyres. The mechanic noticed oil leaking from cam magnet solenoid. I changed both the sensors too. After 25k K/M of usage the car started to consume a lot of fuel. (from the meter it was showing like 16L/100KM that's quite a lot and loss of power too) finally I've got the CEL and I hooked up OBD2 scanner and found 2 errors P0171 and P0137. After couple of google search I've found out that this happens because of the engine oil leaks through the Cam Magnet Sensor and migrates to ECU, MAF and O2 Post Cat Sensor's connectors and alters the resistance from those sensors and make ECU the to misbehave. I have checked those said connectors and found oil contamination.

Solution:-
I took out whole engine wiring harness and soaked into soap water for 24 hours, and made it dry under the sun for 2 weeks and bought a can of CRC Contact cleaner, sprayed on all the sensors interface and wiring connectors to make sure 100% dry and clean. Mean time I've serviced the throttle body, cleaned intake manifold, changed to new intake manifold gasket. I have successfully installed the wiring harness back and started the engine and the engine runs smoothly and power also back to its original state. I cleared the fault codes. However the fuel consumption was still very high. After few minutes of test drive the CEL appeared again. I hooked up my OBD2 scanner and found P0171 error only. This time P0137 was not appeared.

I suspect it could be MAF Sensor issue. Has anyone faced this kinda issues? if yes please kindly share your solution

Best Regards,

Vasan


----------------
1990 W124 230E
2005 W203 C230K Avantgarde SE

Threaded | Newest First Previous Topic | Next Topic | Top

Register To Post